ftu

First-time use of PHsPeed after upgrade or installation.

PHsPeed contains a special Xammp edition so that you can switch between PHP versions during development/testing time. Since version 1.1. only PHP 7.4 and PHP 8.0 are installed. The other packages since PHP 7.1 are also available, but you need to download en install them yourself. The packages can be found on our download page.

If you cannot run a generated application and get the message 'webserver is not running' then there are a few things to checkout.

(If you have issues after upgrade then please install our new license manager. We've added some functionality that should fix most of the issues).

At first:

Within the IDE:

  • Go to the right PHsPeed Xampp section and click 'change.'
  • Select PHP 8 and click on activate PHP.
  • Close PHsPeed and restart by clicking on the desktop short-cut.

Second with Total Commander or File Explorer:

  • Go to your install directory and find the \xampp folder. Here you will find the installed php versions, and one of them is called 'php'. It is the current selected apache version. On upgrades it is possible that this folder is not removed. If all the php version directories that you are using are there, then remove the php folder and try the above steps.

PHsPeed restarts with both Apache as MySQL green. As of now, you are also able to add other packages and switch PHP versions during development. If this doesn't work, please contact support so that we can help you.

  • ftu.txt
  • Last modified: 2021/04/10 10:31
  • by aducomadmin